Unsuppress method not working

I only seem to be able to get a 404 back from the unsuppress method. I've tried every combination json/xml/post/get data I can. It seems strange that the suppress method takes a posted JSON packet, and the unsuppress expects a single email address on the query string?

Can someone else confirm whether or not this method works at all?

Thanks

teejay_hh, 11 months ago

What a shame that the support staff does not take any interest to reply.  I need to implement the api in our site and once I am on the unsurpress functionality I will check back.

Phil Phil, 11 months ago

Hi tshannon,

I'm so sorry for the delay in replying (teejay_hh - you are right to take us to task). The most common mistake that people make with the unsuppress route is that it uses the PUT verb (rather than GET or POST).

Using PUT is fairly common through our API, and is normally used to change the state of an existing resource (ie a suppressed email).

In your post you mentioned that you "tried every combination json/xml/post/get", so it looks like you might not have tried PUT.

In general, the safest thing to do with our API is to simply use one of the existing client libraries. They all abstract this sort of detail away from you, and the result is normally much simpler than fiddling around manually creating the HTTP requests.

Let me know if you're still having issues.

Sign up for free.
Then send campaigns for as little as $9p/m

Create an account