Bulletproof buttons duplicating when forwarded from Outlook

I just used a bulletproof button for the first time. My client noticed that when they forward the email from Outlook, the button shows up twice - once formatted properly and once without the background image. See screenshot: http://webnicki.com/email-button-problem.jpg
It doesn't happen with any other email client I've tried, only Outlook.

Has anyone encountered this? Any idea what to do about it?

I know, we want people to use FORWARDTOAFRIEND instead, but they're going to forward directly anyway!

jonnocohen, 1 year ago

I've just had a similar issue, but with the original mail, not a forwarded one.

What I discovered was when I ran the email through a CSS inliner, both CM's own at inliner.cm or Email on Acid's one, is that they stripped out the CSS property

mso-hide:all

from the link for the button (the one that appears just after

<![endif]-->

). As far as I can tell, that property targets Outlook and hides the element - the second button in this case - while the first one isn't rendered by other clients because it appears inside an Outlook-targeting comment so that only Outlook renders it.

When I added that property back in, the email rendered fine, with just the one button - the nicely styled one - showing up in Outlook. Maybe Outlook itself is stripping out the mso-hide property when it forwards the email? If that's the case, my guess is there won't be an easy fix, and you'll have to choose a compromise, whether it's having two buttons when it's forwarded from Outlook, using simple, ugly, unstyled buttons, or using images for your buttons.

ccarnes, 1 year ago

I know this isn't the answer, but I have worked around the issue by unchecking border color.

I'm no expert on MS conditionals, but I want to say it has something to do with the code that's output since the placement of the closing </v:roundrect> is different when toggling the border color checkbox — it appears either midway through the code (border color on), or near the end (border color off).

thomaus, 10 months ago

I found that instead of relying on the style tag: mso-hide:all; to work, I added:
<![if !mso]>
<a regular button formatting>SUBMIT</a>
<![endif]-->

I could then get forwards to work within Outlook without doubling up the button.

Sign up for free.
Then send campaigns for as little as $9p/m

Create an account