Submit fails on first attempt, works on second attempt

Hi there.

I copied and pasted the form code from the set up page and pasted it into my web template.

Now, when I hit that page and fill in my name and then my email address I get the following:

Sorry, but the email address you supplied was invalid and needs to be fixed.

Click here to go back to the form and make the required changes.

I then click to go back and resubmit the same data and the it adds me fine. Why is this? Can anyone shed some light. Like I said, I pasted the code AS IS... no change.

See the page here:

It might be worth mentioning that the site is built in expression engine - but I can't see that that would affect it. UNless theres some weird post data being sent along that confuses EE.

Any help would be appreciated.

// EDIT: Oh, I also tried clearing cookies. No joy.

Mathew Mathew, 8 years ago

The first thing to check in these cases is that you have not changed the 'name' of any of the form elements - changing it can cause the error you are seeing.

Get in touch with us on Twitter:
We're also on Facebook:
Morg, 8 years ago


Thanks for the reply. Thought the system would mail me to tell me there were replies.

As mentioned in my initial post, I didnt touch the form... just straight up copied and pasted. Whats weird is that it works on the second attempt... Also, some people tell me that their submission goes through on the first attempt.

Could it be something to do with the router we use?

Mathew Mathew, 8 years ago

Can you give us an example of an address that does not work?

Get in touch with us on Twitter:
We're also on Facebook:
Morg, 8 years ago

Yes. see my initial post.

Also, not to be rude, but I thought my post was quite detailed... all the stuff you are asking is in there.

Mathew Mathew, 8 years ago

Hi Morg,

I actually asked for an example email address that does not work. Can you give me one you have tried that does not work, so we can replicate the issue?

Get in touch with us on Twitter:
We're also on Facebook:
travisbell travisbell, 8 years ago

Hey Morg,

I just tested your form and was able to submit my "test" email perfectly fine. I would be interested in knowing what address you are testing as well.

Travis Bell

Join 200,000 companies around the world that use Campaign Monitor to run email marketing campaigns that deliver results for their business.

Get started for free