Images not downloading

I'm trying to load my new campaign from our website. The HTM file uploads, but the graphics do not. (The graphics are in an "images" folder.)  Anyone else had this problem.  We had no problem last month, and we're not doing anything different for this month's campaign.

Andrew.R, 8 years ago

I'm getting this issue too. I have a front-end site on the service and none of the images are appearing in the templates. Previews of old campaigns show up fine but adding new images doesn't work.

I know there must be a few support issues to be sorted right now and normally, I wouldn't mind but I have someone wanting to send out a campaign with events that are in the near future and they can't send until the image loading is working.

In my case, it seems to be using the URL of the custom domain for images and not the c/send URL so they are at:

http://customdomain.com/..../image.jpg
instead of
http://customdomain.csend.com/.../image.jpg

Dave Dave, 8 years ago

Guys, fire the details through to us and we'll have a look at each issue for you.

Andrew.R, 8 years ago

For people needing a quick fix for this, you can setup a .htaccess file on your custom domain that will redirect the links to the right place. This will redirect through the links and maintain the stats (though it might mess up some referrers, I'm not sure). You just right-click the broken image link and try opening it in a new tab. You should see the image show up as something like:

http://customdomain.com/ei/..../image.jpg

The images aren't on your custom domain but rather:

http://customdomain.createsend.com/ei/..../image.jpg

so for this example, create the folder 'ei' at the root of your custom domain and add a .htaccess file in it (assuming your domain's Apache server supports mod_rewrite) and put in the code:

Options +FollowSymLinks
RewriteEngine on
RewriteRule ^(.*)$ http://customdomain.createsend.com/ei/$1

replacing customdomain with your own. Do the same for the links, which for me were in a /t folder where I added a .htaccess file saying:

Options +FollowSymLinks
RewriteEngine on
RewriteRule ^(.*)$ http://customdomain.createsend.com/t/$1

This works for editor preview images and final images. I had to get a client's emails out today so for urgency, you can use this method without any problems until the domain lookup points to the right place.

Join 200,000 companies around the world that use Campaign Monitor to run email marketing campaigns that deliver results for their business.

Get started for free
1-888-533-8098