CM Reporting Data not matching Google Analytics Data

I sent a campaign that indicates 157 unique clicks on links leading to the client's site, but the Google Analytics account for the client site only reports 45 unique visitors for that day.  I'd be ok with maybe a 10-15% difference, but that's a big gap.  I wouldn't think that many people have cookies turned off, and can't think of the reason for this discrepancy.  Any thoughts?
-Red Ember

rob.gevers, 7 years ago

mmmm, no followup on this post? It's a month ago that it is posted.......

I discovered today the same in my campaign: CM says 363 unqiue people clicked a link, but google analytics says 146 unique visitors.....thats a massive gap !!!!

Rob

Stig Stig, 7 years ago

Hi Rob,
I agree that it's an unusually big gap. Some potential sources of error off the top of my head:

* Browsers with javascript turned off/without javascript support (CM would track these clicks, but not GA)
* Several subscribers using same computers (Hard to say without details on your list)
* URLs breaking, causing utm-tags to fall off
* Subscribers clicking but not reaching the site (Any downtime on the website?)
* The site being loaded without the Analytics javascript being loaded (Could happen with unstable connections)

I might be reaching with some of these, but do any of them seem likely in your case?

Also, you probably know that it takes a few hours for data to show up in GA, while CM's reports are live. But if you're seeing the same thing after a month, that's not the explanation.

Stig


The Campaign Monitor Blog – HTML email smarts to go with your good looks.
rob.gevers, 7 years ago

Stig,

Thanks for your reply, hererby my comments:

* Browsers with javascript turned off/without javascript support (CM would track these clicks, but not GA)

--> I can't believe that so many people have this turned off, in the site a lot off javascript is used for layout & navigation: if so many people had js turned off, it would lead to compalints about the look and feel of the site...

* Several subscribers using same computers (Hard to say without details on your list)

--> Nope it are 1700 subscribers of a travel company

* URLs breaking, causing utm-tags to fall off

--> it are real short urls, like www.domainname.com/page.html

* Subscribers clicking but not reaching the site (Any downtime on the website?)

--> zero downtime (confirmed by server stats / logs)

* The site being loaded without the Analytics javascript being loaded (Could happen with unstable connections)

--> don't believe that so many people have unstable connections in a country as the Netherlands

Also, you probably know that it takes a few hours for data to show up in GA, while CM's reports are live. But if you're seeing the same thing after a month, that's not the explanation.

--> It's more than a week ago

Rob

Dave Dave, 7 years ago

Great ideas Stig. Rob, I'm a little stumped as to why there would be such a gap too. I can definitely confirm that the numbers we are reporting on are correct, you have definitely had that number of unique clicks.

In the past I've found the numbers to be quite consistent between the two. Anyone else noticed this kid of discrepancy?

rob.gevers, 7 years ago

My next campaign i'm gonna do a split test:

50% send out with CM
50% send out with my own Email Markting System

I will compare the results of both system with GA
and will inform you if i find some inconsistencies

Rob

Rob

BraceRosso, 7 years ago

Bump to Rob for the comparison results.  Glad that this topic generated some interest, and looking forward to hearing what's up.
-RedEmber

Join 200,000 companies around the world that use Campaign Monitor to run email marketing campaigns that deliver results for their business.

Get started for free
1-888-533-8098