Slow access from one computer

I've complained to Freshview, I've complained to my ISP but I've discovered that the following problem is almost certainly with my computer. For the last couple of weeks, both the Campaign Monitor and Mail Build site have become dog slow to navigate. Each page takes 30 - 60 seconds to load which is a hugh pain when trying to use the app or demonstrating to a customer on the phone. Mathew has assured me that there are no problems at their end and I've had a couple of friends test from their ISP and it is fine.

I blamed my ISP but I've just discovered that it works fine using another computer in our network. So I figured it must be a caching issue. I cleared the cache and downloaded a tool that REALLY clears the cache in case it had become corrupt. No luck.

I tried Firefox instead of IE but no luck.

So it really does sound like it has something to do with my computer which seems strange. I don't experience this when visiting any other sites. Could someone point me in the right direction?

Mathew Mathew, 8 years ago

Is it the site - or the application - or both?

Get in touch with us on Twitter:
We're also on Facebook:
CleverDick CleverDick, 8 years ago

Both - and

And I just tried loading on my computer (68 seconds) vs my other computer (5 seconds).


Ben Ben, 8 years ago

Is it the initial load, as if it's just trying to find the server, or is that 68 seconds for the entire page to load, including all images?

If it's the initial load, it could be a problem with your DNS servers maybe? You could try using OpenDNS and see if it makes a difference.

Join 200,000 companies around the world that use Campaign Monitor to run email marketing campaigns that deliver results for their business.

Get started for free