repeater image not replacable

hi there,

first of all: i'm kind of new and want to test campaignmonitor for a client. i am absolutely amazed by the interface-design and simplicity of this page. thumbs up for this!

my problem: i try to implement one repeater (including 1 image, 1 title, 1 description - though sad there couldnt be more, i would love to have two titles). but in the editor, the replace button for the image doesnt show up.


as i have a same-coded footer part in which the image IS replacable, I'm kind of lost. i thought it was possible to edit  the image inside the repeater tags with the replace button. Am I mistaken? Any help is greatly appreciated!

the non-functioning code-part:

<repeater toc='false'>
            <table width="100%" border="0" cellspacing="0" cellpadding="0"><tr>
               <td width="100%" valign="top" style="background-image:url(images/bg_rep.jpg); background-repeat: no-repeat; background-position: 50% 100%";>
                     <img src="<$imagesrc link='true' default='images/image.jpg'$>" alt="blabla" width="220" height="298" align="left" style="margin: 0px 20px 0px 0px;">
                 </div><div class="h1"><$title default='insert title here'$></div> <$description link='false' default='<p>copy text'</p>$>
                
               </td></tr></table>
                  </repeater>
nomisum, 6 years ago

maybe i figured out by myself: there is no replace button when using <repeater>.

instead i have to delete the image when editing the whole part and upload another. wonder why this is different though. makes no sense to me and is less usability-friendly.

thanks 2 anyone stumbling over my problem ;)

btw: i was really getting crazy about this stupid thing ... xD

alvarix, 6 years ago

I am having similar issues getting the replacable image to appear.

Supposedly you can have a replacable img in a repeater:
http://sitel.createsend.com/help/topic.aspx?t=129#repeater

I have tried all kinds of code variations, but the default img wont show, nor will any update buttons.

I sent an email to support.

alvarix, 6 years ago

Looks like I was just confused by the UI.
In a repeater you edit all the elements in one window, so you dont see an edit icon next to the img.
Also, it doesn't show you the default img on the page, only in the edit window or when you've added a section.

Argh, many hours wasted because of bad ui.

davidaf davidaf, 6 years ago

Hi Alvarix,

I do apologize for any problems you've had with the UI. You should be seeing the default img on the page when you first open the template in the editor, it sounds like there may be an actual issue going on. Could you contact support with the details on which template you are having these problems with so we can take a look and see if there's a bug in the system that needs to be addressed?

You are correct that if the image is within a repeater that you can't replace the image independently. All the items in a repeater are edited as a single unit when you click the Edit icon.


The Campaign Monitor Blog – HTML email smarts to go with your good looks
Phil Phil, 6 years ago

Hello Alvarix and nomisum,

We went live with some changes just this afternoon, and in response to your comments here included a change to the behaviour of images within repeaters, while editing the campaign. Changes are as follows:
1. All images will now have the "replace" overlay
2. If no image is yet present, you will be presented with a blank "placeholder"
3. If you click this image, it will then offer you a chance to edit that repeater block, including both title/description/image

This should bring the behaviour of images within repeaters in line with that of floating images. Thanks for your comments, we hope these fixes will help you out.

Join 200,000 companies around the world that use Campaign Monitor to run email marketing campaigns that deliver results for their business.

Get started for free
1-888-533-8098