Return to Site Link does not work

I have a subscribe form on my homepage.  When a user enters their info and clicks subscribe they are brought to a page that has a confirmation message.  This page also has a link that says "Click here to return to site" This link does not work.  The link goes nowhere.

How can I fix this?

davidaf davidaf, 6 years ago

Hi drknife,

The go back link is using simple javascript to go back one page in the browser's history. Do you have javascript disabled by any chance?


The Campaign Monitor Blog – HTML email smarts to go with your good looks
drknife, 6 years ago

I do not have java-script turned off.  Also this was brought to my attention by other users of the site.  Should I give you the address of where the subscribe form is to see if we have a problem on our side?

davidaf davidaf, 6 years ago

drknife,

Yes, please.


The Campaign Monitor Blog – HTML email smarts to go with your good looks
drknife, 6 years ago

http://icecreamman.com

davidaf davidaf, 6 years ago

drknife,

It's because you have the post going to target="_blank" which is opening it in a new tab. There is no back history on the new tab, so it has nothing to go back to.


The Campaign Monitor Blog – HTML email smarts to go with your good looks
drknife, 6 years ago

Wow, I cannot believe I did not notice that.  Thank you for the help.

KristenFischer, 6 years ago

Hi there,

I have a similar problem. Can you tell me why when I put in an email address and click subscribe, nothing happens?

Thanks,
Kristen

Join 200,000 companies around the world that use Campaign Monitor to run email marketing campaigns that deliver results for their business.

Get started for free
1-888-533-8098