Repeater Drag and Drop malfunction..

Hi guys,

I'm having an odd issue with a newsletter, that was created from one of your templates.

I can drag and drop the repeater in the editor and it moves, but when I save it it moves back to its original position.. the only solution I can see is to re-do all the items and titles in the order that I want them.

currently, I have the repeater wrapped with <td>, and then a nested table inside the repeater.. It's a little different than the others who have said that their repeaters are not moving at all. Mine move, I then save the e-mail changes from the editor and view the preview, but then the old positions have moved back again.

Any ideas?

-Mikey

Stig Stig, 6 years ago

Hi Mikey,

We're sorry for the trouble you're having with this, and have received a few emails from others seeing the same problem. It does seem to be a bug that was introduced today, and we've let our developers know so they'll look into it as soon as they can.

For now, our only suggestion would be to enter the content into the campaign after you've decided on an order. We'll post an update once we've had a closer look, so I'd suggest subscribing to the topic.

Stig


The Campaign Monitor Blog – HTML email smarts to go with your good looks.
boldprint boldprint, 6 years ago

I'd like to add that I'm having the same issue. I have had clients call already with the same problem. They have an email they'd like to get out today. I am going to end up recreating their draft with the articles in the right order. Please let us know as soon as this is resolved!

Thanks,
Susan

lischq, 6 years ago

My clients are having the same issue. A couple of the campaigns are time-sensitive, so any ETA you could give on a fix for this bug would be much appreciated.  I'm pretty sure my clients were not having this problem before today.
thanks,
T.

roshodgekiss roshodgekiss, 6 years ago

Hi folks, we're really sorry for all the trouble this repeater issue has been causing you and your clients. As Stig mentioned above, we pushed an update yesterday and this unexpectedly occurred during the process. Our devs consequently identified the issue and applied a fix this morning.

Please give this a shot again in the template editor and let us know if you still experience any problems with arranging repeaters. Many thanks to all of you for helping us nail this bug and hanging in there - we're hoping that will be it in terms of post-update chaos.


Get in touch with us on Twitter: http://twitter.com/campaignmonitor
We're also on Facebook: http://facebook.com/campaignmonitor
boldprint boldprint, 6 years ago

Thanks for the quick fix!

PMcKern, 6 years ago

This kind of thing has been happening to me a lot this week. You turn around, and a number of items in a repeater group has reordered itself. I believe that all the items had been entered in the correct order in the first place. In one particularly embarrassing case, my in-house client was wandering by as I was trying to drag a mixed-up group back into order, and items kept changing identity as I dropped them. It was like some kind of hallucination, not confidence-inspiring. I hope this week's assorted bugginess can be sorted out soon.

pixelglory, 5 years ago

Don't mean to resurrect an old thread but I am experiencing this exact issue on an auto responder I just setup.  Is anyone else experiencing this still?

Phil Phil, 5 years ago

G'day,

There's definitely no need to apologise for complaining about a bug, even if it is an old one!

There was an issue which applied to autoresponder repeater content only. We've just pushed live a fix, and you should find that autoresponders are now reordering exactly as you need them to. If you have any further problems, please let us know.

Phil

pixelglory, 5 years ago

Thank you so much!  I appreciate the quick fix.

Dana

paulgalatis, 5 years ago

Hi all,

This issue seems to have cropped up again. Since last night we cannot drag and drop andy of our repeaters. Campaign Team, please help!

Thanks.

I am Paul

roshodgekiss roshodgekiss, 5 years ago

Hi Paul, could you kindly contact our support team in regards to this issue and mention the campaign you're working on, plus which browser you're using? That will greatly assist us in reproducing the repeater issue on our end. We're really sorry about this and hope we can get you using the template editor as per usual shortly.


Get in touch with us on Twitter: http://twitter.com/campaignmonitor
We're also on Facebook: http://facebook.com/campaignmonitor
mailninja mailninja, 5 years ago

Hi,
I just finished a new template with the new editor and I am unable to drag and drop any of the repeaters. I appreciate any help you van provide. The template is under my client (Filta)

roshodgekiss roshodgekiss, 5 years ago

Hi mailninja, could you kindly check if it's layouts inside of repeaters that you're trying to drag and drop? Repeaters themselves cannot be moved around, just the editable regions surrounded by <layout> tags.

For more information on layout usage, take a look at our template tag docs.


Get in touch with us on Twitter: http://twitter.com/campaignmonitor
We're also on Facebook: http://facebook.com/campaignmonitor

Join 200,000 companies around the world that use Campaign Monitor to run email marketing campaigns that deliver results for their business.

Get started for free
1-888-533-8098