Content not appearing in Hotmail or Live Mail

I have a campaign that I'm testing:

http://www.wre.uk.com/recreate08/index.htm

it's not my design, I've just been tasked with turning it into HTML. </weasly-disclaimer>

I've run it though a design test, and it passes fine on just about everything except Hotmail and Live Mail, where the message shows up, but absolutely no content gets displayed. I've tried sending it to my own Hotmail account, and I get the same result. However, when I view source, the email content is all there, Hotmail just isn't displaying it for some reason.

Am I just (missing something) stupid?

TIA
Ian

Mathew Mathew, 8 years ago

We've seen this before, and the answer was an unclosed comment tag in the head somewhere that other clients were automatically closing, but Hotmail was not.

I'd suggest cutting the whole stylesheet out to start, and see if the content shows up.


Get in touch with us on Twitter: http://twitter.com/campaignmonitor
We're also on Facebook: http://facebook.com/campaignmonitor
acidproductUK acidproductUK, 8 years ago

Thanks Mathew. I had tried removing the comment tag altogether but that didn't make any difference. In the end it was moving the style sheet into the <body> tag that worked. Of course, that then broke Google so I had to leave a copy in the <head> tag as well. Messy, but it all works now!


Ian Davies
Acid Product
Audio Visual Presentations, Web Design, Print Design and Creative Technology Consultancy in Rugby, UK

Join 200,000 companies around the world that use Campaign Monitor to run email marketing campaigns that deliver results for their business.

Get started for free
1-888-533-8098