Images donwloading only partially in Outlook?

Well this is an new nervous breakdown to have!

I am sending my client test emails from Campaign Monitor and he is getting only partial downloads of the images. Like, maybe a 4th of each will download.

I don't let CM store my images for me, I hard-code a full URL path to all my images, so they always reference images on my own hosted domain.

The weird thing is I have sent him some old emails just to test, and they come through fine!

Any advice?

Jarrod Jarrod, 5 years ago

Hi bopjo1,

Can you please post your code so we can take a look?

Are you able to reproduce this problem yourself?

Has your client tried looking at the newer emails in a different email client? Same result?

It may be best you email support so we can take a look at your account too.

bopjo1 bopjo1, 5 years ago

Actually, we found the culprit to be this snippet of code:


...which we were using (as discovered on these forums) as a method to control line-height in Outlook. When we stripped that code out, the images downloaded fine.

It may be because I place most of my CSS in <td> tags, not paragraphs. Perhaps placing mso-line-height-rule:exactly; in the <td> tags caused the images in those table cells to not align correctly and appear partially downloaded. I'm not sure.

Jarrod Jarrod, 5 years ago

Hi bopjo1,

Nice find! Thanks for letting us know.

Join 200,000 companies around the world that use Campaign Monitor to run email marketing campaigns that deliver results for their business.

Get started for free