Street address has no line breaks from template builder

When I contruct a template using the new template builder (love it), and using 'Image or product gallery' as a starting point, when I enter the street address it's on multiple lines and the preview shows it on multiple lines. However when it's sent the street address just runs together onto one line with no <br>'s or <p>'s. If I export the template it also has no <br>'s or <p>'s. Any ideas how to relaiably get the address shown on multiple lines?

--

roshodgekiss roshodgekiss, 5 years ago

Hi redleaf01, this happens because we've used white-space: pre-wrap; to add line breaks in the address field - while this works in Apple Mail and others, sadly, this isn't supported by all email clients.

At present, the only way to reliably add breaks is to export your template and manually add <br /> where required. On our end, we'll certainly look at how we can improve this, either by making it editable in the template editor, or by using <br /> instead of CSS instead. Thanks for your feedback on this! :D


Get in touch with us on Twitter: http://twitter.com/campaignmonitor
We're also on Facebook: http://facebook.com/campaignmonitor
redleaf01, 5 years ago

The problem is if I add <br>'s and import the template then it becomes double spaced in the preview (and I guess in Apple Mail) so this isn't really a fix?

redleaf01, 5 years ago

OK I removed white-space: pre-wrap; too and that seems to work OK

roshodgekiss roshodgekiss, 5 years ago

Perfect redleaf, that's the way. Sorry about this funkiness, we'll look into getting it fixed in the future.


Get in touch with us on Twitter: http://twitter.com/campaignmonitor
We're also on Facebook: http://facebook.com/campaignmonitor

Join 200,000 companies around the world that use Campaign Monitor to run email marketing campaigns that deliver results for their business.

Get started for free
1-888-533-8098