Layout tag not aligning to the appropriate layout in a Repeater

I have an email that has 4 Layouts in 1 Repeater.
The first layout shows the  "Add New" controller a position that is useful and convenient.
The second layout shows the "Add New" controller inside the content area of the second layout, overlapping text.
The third layout does not show the "Add New" controller near the layout container, it is pushed down the page.
The fourth layout "Add New" controller is at the bottom of the page with a large white space above it. In order to add an additional layout, you have to click on the controller then, wait for the browser to activate the Javascript functions to add a dropdown menu. This is all very confusing in how I am writing this but, what I am trying to ask is why are my Layouts not functioning as expected when trying to add new layouts and re-order the layouts.

This is correct http://api.cld.me/Gkp9/Screenshot%202012-05-19%20at%201.31.21%20AM.png

This is not correct http://f.cl.ly/items/0I1D0u2V1v173o2D1E27/Screenshot%202012-05-19%20at%201.24.01%20PM.png

This is REALLY not correct http://f.cl.ly/items/461F1f1B1P2I2y1q1I1r/Screenshot%202012-05-19%20at%201.23.52%20PM.png

Stephen, 4 years ago

Hey Frederick,

Thanks for your question and sorry to see you're having these layout issues here, however after just logging into your account to take a look at the template in question here, I think the problem may just be the div below which you're wrapping around each layout table in order to ensure each one is centered and appears below the previous one:

<div class="divContainer" style="display: block; float: left; margin-left: auto; margin-right: auto; margin-top: 0; margin-bottom: 0; padding-left: 0px; padding-bottom: 0px; padding-top: 0px; padding-right: 0px; width: 580px; max-width: 580px;">

Just in case you're not aware, Outlook 2007 / 2010 doesn't support the float property either, so instead what I did was remove all those divs from your template and added a single <br /> tag after the closing </table> tag within each layout instead (to ensure the following layout table begin on a new line beneath), and have uploaded this amended template as a new template in your account called "Daily Gourmet template test". I've also created a copy of your existing draft campaign which uses this template, and so if you log in and take a look, hopefully those 'edit' bars are displaying a little more consistently for you now?

Thanks again and I hope that helps.

oneblackcrayon oneblackcrayon, 4 years ago

@Steven - That worked! THANK YOU very much for your fix! So removing the div and adding a break <br> tag below end </table> fixed the issue. :-)

Stephen, 4 years ago

No problem at all Frederick, glad I was able to help :)

Join 200,000 companies around the world that use Campaign Monitor to run email marketing campaigns that deliver results for their business.

Get started for free
1-888-533-8098