Segment - Count Result on Multiple Choice Field

I found this post , but I'm not sure if that is exactly the same or if that bug is even still 'out there'.  My apologies, if this is a duplicate.

I was just working on cleaning up some of our list and segment naming conventions, to clarify for a newer worker. 

In our primary list, we have almost 13,000 subscribers.
We have a custom field of type "Multi-Options (select many)" with two values provided. It can be both, one choice or nothing.

I have 4 segments that should be telling me the breakdown, but I'm seeing numbers that are WAY too low, and don't match the subscriber data when I export the active list to a .csv

Criteria :: Count :: Expectation from CSV file
No Value Provided :: 73 ::  correct
Value A :: 215 :: 12,712 (if will include when other values exist) or 12,481 (if only solo entries count)
Value B :: 1 ::  348 (if includes when other values exist) or 117 (if only solo entries count)
Value A and Value B :: 1 :: 231


I'm completely stumped.  I thought maybe we had a form putting in a third value somehow that I couldn't check for, but would appear in the exported subscriber detail, but no "luck". 

Is this the symptom of a system-wide bug or is something with wrong my with configuration?  If the latter is the case, please let me know how I should try to troubleshoot further.  I'm just stumped.

Thank you,
Elizabeth

roshodgekiss roshodgekiss, 4 years ago

Hi there Elizabeth, I've just sent you an email - we'd really like to see what's going on, but require a few more details from you first. Sorry for the trouble!


Get in touch with us on Twitter: http://twitter.com/campaignmonitor
We're also on Facebook: http://facebook.com/campaignmonitor

Join 200,000 companies around the world that use Campaign Monitor to run email marketing campaigns that deliver results for their business.

Get started for free
1-888-533-8098