Outlook.com remove display support?

Has Outlook.com (OWA) removed support for the display property? I've tried several different methods of testing "display: none" and it seems to be stripped out no matter the method. Here's the code I used to test different methods of adding the display property. Whether the style is inline, in the head, or in the body, nothing seems to give any results.

<head>
<style>
    #displayNone {
        display: none;
         border: solid 1px black;
    }
    #displayNoneImportant {
        display: none !important;
         border: solid 1px black;
    }
    #displayNoneDisplayNoneImportant {
        display: none;
        display: none !important;
         border: solid 1px black;
    }
</style>
</head>
<body>
    <style>
    #displayNone {
        display: none;
         border: solid 1px black;
    }
    #displayNoneImportant {
        display: none !important;
         border: solid 1px black;
    }
    #displayNoneDisplayNoneImportant {
        display: none;
        display: none !important;
         border: solid 1px black;
    }
</style>
<table>
  <tr>
    <td style="display: none; border: solid 1px black;"><span style="display:none;">01</span></td>
    <td style="display: none !important; border: solid 1px black;">02</td>
    <td style="display: none; display: none !important; border: solid 1px black;">03</td>
    <td id="displayNone">04</td> 
    <td id="displayNoneImportant">05</td>
    <td id="displayNoneDisplayNoneImportant">06</td>
  </tr>
</table>
</body>
adamkimmerer, 3 years ago

If anyone else runs into this problem a fix I found was to set the cell to font-size: 0px;

See why 200,000 companies worldwide love Campaign Monitor.

From Australia to Zimbabwe, and everywhere in between, companies count on Campaign Monitor for email campaigns that boost the bottom line.

Get started for free